# Can't Deployments

**URL:** https://replit.discourse.group/t/cant-deployments/6350
**Category:** Deployments
**Created:** [August 5, 2025, 9:49pm UTC](https://replit.discourse.group/t/cant-deployments/6350 "2025-08-05T21:49:49Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![nhatquangph2](https://avatars.discourse-cdn.com/v4/letter/n/45deac/32.png) [@nhatquangph2](https://replit.discourse.group/u/nhatquangph2)
#### Post date: [August 5, 2025, 9:49pm UTC](https://replit.discourse.group/t/cant-deployments/6350/1 "2025-08-05T21:49:49Z")

</div>

Subject: Database Migration Platform Issue Preventing Deployment

Description:

- Deployment fails with database migration platform error
- Error message: “Database migration failure is preventing deployment”
- This appears to be a platform-level issue, not code-related
- Application runs successfully in development environment
- Request: Platform team assistance to resolve migration system issue

Technical Details:

- Project: [Your project name]

- Database: PostgreSQL with PostGIS extension

- Framework: Full-stack JavaScript (React + Express)

- All code errors have been resolved

---

<div class="post-metadata">

### Author: ![mark](https://yyz2.discourse-cdn.com/flex010/user_avatar/replit.discourse.group/mark/32/196_2.png) [@mark](https://replit.discourse.group/u/mark)
#### Post date: [August 6, 2025, 6:04pm UTC](https://replit.discourse.group/t/cant-deployments/6350/2 "2025-08-06T18:04:19Z")

</div>

Have you tried to debug with Agent? Did you send Replit team a support ticket?

You might want to put in a ticket to get some Replit team eyes on that.

I haven’t run into this yet/before.

---

<div class="post-metadata">

### Author: ![angelov204](https://avatars.discourse-cdn.com/v4/letter/a/47e85d/32.png) [@angelov204](https://replit.discourse.group/u/angelov204)
#### Post date: [August 19, 2025, 3:27pm UTC](https://replit.discourse.group/t/cant-deployments/6350/3 "2025-08-19T15:27:38Z")

</div>

I’m having this exact issue. I contacted support and they said the will investigate because its a platform migration issue so now I’m stuck. Just happend yesterday, let us know if they find a solution, I will do the same.

---

<div class="post-metadata">

### Author: ![mark1051](https://avatars.discourse-cdn.com/v4/letter/m/a9adbd/32.png) [@mark1051](https://replit.discourse.group/u/mark1051)
#### Post date: [October 7, 2025, 3:07pm UTC](https://replit.discourse.group/t/cant-deployments/6350/4 "2025-10-07T15:07:14Z")

</div>

Hi I have the same issue and have logged a ticket over three days ago with support and still have not had this fixed. Has anyone’s issue been solved? Please help?

---

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [February 2, 2026, 2:59pm UTC](https://replit.discourse.group/t/cant-deployments/6350/5 "2026-02-02T14:59:26Z")

</div>

So now the issue is a postgis version mistmatch between dev (3.3) and production (3.5). Causing db migrations to fail, because it attempts to update postgis tables. I´m stuck for a week already. So atm postgis cant not be used as there is no workaround as far as I can see
