# Blocker - Postgis db versions mismatch - deployment fails

**URL:** https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798
**Category:** Bugs
**Created:** [February 2, 2026, 3:16pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798 "2026-02-02T15:16:55Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [February 2, 2026, 3:16pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/1 "2026-02-02T15:16:56Z")

</div>

Dev is running PostGIS 3.5.x while prod is on 3.3.x. During deploy, migrations attempt to alter `spatial_ref_sys` (a PostGIS-owned table), which fails in prod due to missing upgrade paths and lack of table ownership.  
This blocks production deployments.  
Overwriting (copying) production db does not fix the issue as postgis versions persist.

Also tried excluding PostGIS tables/schemas in Drizzle, but Replit ignores those rules, so `spatial_ref_sys` still attempts to alter those tables.

Several tickets opened and merged into #276697

To reproduce:

1. add postgis extension on db.
2. Deploy.
3. Any subsequent deployments will prompt to either: A) Overwrite production B) Cancel

---

<div class="post-metadata">

### Author: ![realfunnyeric](https://yyz2.discourse-cdn.com/flex010/user_avatar/replit.discourse.group/realfunnyeric/32/2150_2.png) [@realfunnyeric](https://replit.discourse.group/u/realfunnyeric)
#### Post date: [February 2, 2026, 6:32pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/2 "2026-02-02T18:32:13Z")

</div>

@FranciscoCM maybe flag this up? Sounds sticky and possibly platform-side.

---

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [February 2, 2026, 8:53pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/3 "2026-02-02T20:53:04Z")

</div>

Thanks @realfunnyeric I´ve been stuck for a week, easy to reproduce. Im software engineer myself. Seems 100% platform related. No workaround posible, besides dumping production db on each relase.

---

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [February 4, 2026, 8:15am UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/4 "2026-02-04T08:15:48Z")

</div>

> [@realfunnyeric](#):
>

Hi @FranciscoCM or @realfunnyeric would you have any idea wether this will be resolved anytime soon, or an estimate?

I have spent nearly 1k on this project and I have wiped production database like 10 times. It is not an option anymore.

Also I havent received any technical support so far. All I know is it was escalated but this was nearly 2 weeks ago.

Thanks

---

<div class="post-metadata">

### Author: ![FranciscoCM](https://yyz2.discourse-cdn.com/flex010/user_avatar/replit.discourse.group/franciscocm/32/1693_2.png) [@FranciscoCM](https://replit.discourse.group/u/FranciscoCM)
#### Post date: [February 4, 2026, 4:55pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/5 "2026-02-04T16:55:23Z")

</div>

Hey @cmarradesc so sorry to hear about the issues you are having here!  
Can you please share a ticket number with me? With that I can further flag internally!

---

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [February 4, 2026, 5:40pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/6 "2026-02-04T17:40:46Z")

</div>

Hi , thanks Frandisco.

I have main ticket 276697  
Here is another ticket in another account: 276697  
And here is a link to anoter simple project you can reproduce (feel free to push or do any changes): [Sign Up - Replit](https://replit.com/join/uwdpiyzqtl-dreambighat)

---

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [February 25, 2026, 10:42am UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/7 "2026-02-25T10:42:02Z")

</div>

It´s unfortunate this was never resolved. After dropping my production database for 6 times in hope it would be eventually resolved, I decided to rewrite all queries using these tables and drop the extension.

Assume there is a long TODO list in Replit, but it would be a pitty this one got lost in the middle of the noise. As it stands Replit does not support Postgis which is quite important for heavy location based apps.

---

<div class="post-metadata">

### Author: ![realfunnyeric](https://yyz2.discourse-cdn.com/flex010/user_avatar/replit.discourse.group/realfunnyeric/32/2150_2.png) [@realfunnyeric](https://replit.discourse.group/u/realfunnyeric)
#### Post date: [March 18, 2026, 11:05pm UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/8 "2026-03-18T23:05:46Z")

</div>

That sucks. Rewriting all your queries just to work around a platform version mismatch shouldn’t be the answer. Hopefully this gets prioritized. @FranciscoCM

---

<div class="post-metadata">

### Author: ![aehostetler](https://avatars.discourse-cdn.com/v4/letter/a/d2c977/32.png) [@aehostetler](https://replit.discourse.group/u/aehostetler)
#### Post date: [July 2, 2026, 11:28am UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/9 "2026-07-02T11:28:01Z")

</div>

I am dealing with this same issue and have not found an acceptable workaround. Replits suggestion was to add a secret to the account pointing to a dummy database url so deployment would ignore the version diff. Only problem is that ignores all diffs, so I cant make any changes to database content. I would really like to find a solution to this as its holding up my entire project. I’ve been trying to sort this out for 2 months now.

---

<div class="post-metadata">

### Author: ![cmarradesc](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@cmarradesc](https://replit.discourse.group/u/cmarradesc)
#### Post date: [July 2, 2026, 11:43am UTC](https://replit.discourse.group/t/blocker-postgis-db-versions-mismatch-deployment-fails/8798/10 "2026-07-02T11:43:01Z")

</div>

> [@aehostetler](#):
>
> his same issue and have not found an acceptable workaround. Replits suggestion was to add a secret to the account pointing to a dummy database url so deployment would ignore the version diff. Only problem is that ignores all diffs, so I cant make any changes to database content. I would really like to

All I got back was to remove postgis entirely. As far as I know, Replit is incompatible with Postgis unless this issue is resolved.

If I was you, given you are in replit, Id ask the agent to rewrite all queries related to locations. You will waste money, but you´ll invest in health, because it can be very frustrating hoping for a fix, given there is not that many people using postgis.
